Internet eXchange Point на Юге России
О компании Услуги Сеть Участники Справка
Типовые конфигурации

Пример конфигурации BGP на маршрутизаторах Cisco
для подключения к Route Server по IPv4

router bgp MYAS
  no synchronization
  bgp router-id MYLOOPBACK
  no bgp enforce-first-as
  bgp log-neighbor-changes
  network MY.NET.PREF.0 mask 255.255.255.0

  neighbor 91.240.225.1 remote-as 59428
  neighbor 91.240.225.1 send-community
  neighbor 91.240.225.1 soft-reconfiguration inbound
  neighbor 91.240.225.1 route-map RM-IX-import in
  neighbor 91.240.225.1 route-map RM-IX-export out
  no auto-summary

ip route MY.NET.PREF.0 255.255.255.0 Null0 250
ip bgp-community new-format


ip prefix-list PL-default seq 10 permit 0.0.0.0/0
!
ip prefix-list PL-bogon seq 5 permit 0.0.0.0/0 ge 32
ip prefix-list PL-bogon seq 10 permit 127.0.0.0/8 le 32
ip prefix-list PL-bogon seq 15 permit 10.0.0.0/8 le 32
ip prefix-list PL-bogon seq 20 permit 172.16.0.0/12 le 32
ip prefix-list PL-bogon seq 25 permit 192.168.0.0/16 le 32
ip prefix-list PL-bogon seq 30 permit 192.0.2.0/24 le 32
ip prefix-list PL-bogon seq 40 permit 191.255.0.0/16 le 32
ip prefix-list PL-bogon seq 45 permit 192.0.0.0/24 le 32
ip prefix-list PL-bogon seq 50 permit 223.255.255.0/24 le 32
ip prefix-list PL-bogon seq 55 permit 224.0.0.0/3 le 32
ip prefix-list PL-bogon seq 60 permit 169.254.0.0/16 le 32
!
ip prefix-list PL-all seq 5 permit 0.0.0.0/0 le 32
!
ip prefix-list PL-mynet seq 10 permit MY.NET.PREF.0/24
!


!=== BGP community на сети Sea-IX
!0:peer-as 	- блокировка анонса маршрута к указанной AS 
!59428:peer-as	- анонсирование маршрута к указанной AS
!0:59428	- блокировка анонса маршрута ко всем AS
!59428:59428	- анонс маршрута ко всем AS

!=== пример привязки community к анонсу своих префиксов,
!=== ниже добавляется community "не анонсировать 
!=== префиксы из листа PL-mynet для AS12345"

route-map RM-IX-export permit 10
  match ip address prefix-list PL-mynet
  set community 0:12345
!


route-map RM-IX-import deny 10
  match ip address prefix-list PL-default
!
route-map RM-IX-import deny 20
  match ip address prefix-list PL-bogon
!
route-map RM-IX-import permit 30
  match ip address prefix-list PL-all



----------------------------------------------------

Пример конфигурации зоны retracker.local на DNS-сервере BIND

/etc/bind/named.conf.local
zone "retracker.local" {
        type master;
        file "master/db.retracker.local";
        notify no;
};
/etc/bind/master/db.retracker.local
# cat /etc/bind/master/db.retracker.local
$TTL    86400
@       IN      SOA     @ root.retracker.local. (
                        2011050302      ; Serial
                         604800         ; Refresh
                          86400         ; Retry
                        2419200         ; Expire
                          86400 )       ; Negative Cache TTL

@       IN      NS      ns.server.net.  ; здесь указываете имя вашего ns
        IN      A       91.240.225.123  ; IPv4 адрес retracker.local в сети Sea-IX



----------------------------------------------------

Пример конфигурации BGP на маршрутизаторах Mikrotik
для подключения к Route Server по IPv4

Типовая конфигурация составлена Янченко Андреем (root#noutek.com), ООО "Новтек"

# команды указаны в порядке выполнения
/routing bgp instance add name="default" as=MYAS router-id=0.0.0.0 
redistribute-connected=no redistribute-static=no redistribute-rip=no 
redistribute-ospf=no redistribute-other-bgp=yes out-filter="" 
client-to-client-reflection=yes ignore-as-path-len=no routing-table=""

# выполняется для каждого анонсируемого префикса
/routing bgp network add network=NETWORK/CIDR   

# фильтрация префиксов
# BOGON
/routing filter add chain=sea-ix-in prefix=0.0.0.0/0 invert-match=no 
action=discard set-bgp-prepend-path="" set-bgp-communities=""
/routing filter add chain=sea-ix-in prefix=127.0.0.0/8 invert-match=no 
action=discard set-bgp-prepend-path="" set-bgp-communities=""
/routing filter add chain=sea-ix-in prefix=10.0.0.0/8 invert-match=no 
action=discard set-bgp-prepend-path="" set-bgp-communities=""
/routing filter add chain=sea-ix-in prefix=172.16.0.0/12 invert-match=no 
action=discard set-bgp-prepend-path="" set-bgp-communities=""
/routing filter add chain=sea-ix-in prefix=192.168.0.0/16 invert-match=no 
action=discard set-bgp-prepend-path="" set-bgp-communities=""
/routing filter add chain=sea-ix-in prefix=192.0.2.0/24 invert-match=no 
action=discard set-bgp-prepend-path="" set-bgp-communities=""
/routing filter add chain=sea-ix-in prefix=191.255.0.0/16 invert-match=no 
action=discard set-bgp-prepend-path="" set-bgp-communities=""
/routing filter add chain=sea-ix-in prefix=192.0.0.0/24 invert-match=no 
action=discard set-bgp-prepend-path="" set-bgp-communities=""
/routing filter add chain=sea-ix-in prefix=223.255.255.0/24 invert-match=no 
action=discard set-bgp-prepend-path="" set-bgp-communities=""
/routing filter add chain=sea-ix-in prefix=224.0.0.0/3 invert-match=no 
action=discard set-bgp-prepend-path="" set-bgp-communities=""
/routing filter add chain=sea-ix-in prefix=169.254.0.0/16 invert-match=no 
action=discard set-bgp-prepend-path="" set-bgp-communities=""

# принять все остальные префиксы, FullView
/routing filter add chain=sea-ix-in invert-match=no action=accept 
set-bgp-prepend-path=""

# разрешить анонс своих префиксов
# выполняется для каждого анонсируемого префикса
/routing filter add chain=sea-ix-out prefix=NETWORK/CIDR invert-match=no 
action=accept set-bgp-prepend-path="" set-bgp-communities=0:12345      

# не отправлять остальные (пришедшие с других neighbors)
/routing filter add chain=sea-ix-out invert-match=no action=discard 
set-bgp-prepend-path=""

# основной пир -  krd1-rs - 91.240.225.1
/routing bgp peer add name="Sea-IX" instance=default remote-address=91.240.225.1 
remote-as=59428 tcp-md5-key="" nexthop-choice=default multihop=no route-reflect=no 
hold-time=3m ttl=default in-filter=sea-ix-in out-filter=sea-ix-out address-families=ip 
default-originate=never remove-private-as=no as-override=no passive=no use-bfd=no

# резервный пир - krd-rs2 - 91.240.225.100
/routing bgp peer add name="Sea-IX Reserve" instance=default 
remote-address=91.240.225.100 remote-as=59428 tcp-md5-key="" nexthop-choice=default 
multihop=no route-reflect=no hold-time=3m ttl=default in-filter=sea-ix-in 
out-filter=sea-ix-out address-families=ip default-originate=never remove-private-as=no 
as-override=no passive=no use-bfd=no


Справка
Типовые конфигурации
Команды Looking Glass
График загрузки
Новые участники
ООО "Связьресур-Регион"
г. Краснодар, srr
AS34559
ООО "СвязьИнвестРегион"
г. Краснодар, sir
AS203730
ООО "Джи-Кор Рус"
г. Москва, gcore
AS199524
ООО "Рокет Телеком"
г. Краснодар, rocket
AS208142
ООО "СИТИЛАН"
г. Краснодар, citylankrd
AS205781
ООО "Okko"
г. Москва, okko
AS60265
ЗАО "ЭР-Телеком"
г. Москва, ertelecom
AS9049
ООО "24 часа ТВ"
г. Москва, tv24
AS50775
ООО "ЛЕВЕЛ-МСК"
г. Ростов-на-Дону, svcom
AS48276
ООО "ТЕЛЕСТАР КОММУНИКЕЙШНС"
г. Ростов-на-Дону, didi
AS51200
Всего 54 Участника, полный список...
Точки подключения
Краснодар:
  • ул. Калинина, 341
  • ул. Комсомольская, 40
  • ул. Красная, 113

    Ростов-на-Дону:
  • ул. Мясникова, 54
  • ЦОД - площадки
    Краснодар:
  • ул. Комсомольская, 40, ИП Езерская (Орбита)
  • Информация о программе...
    ООО "АйпиНетком" / adm@sea-ix.ru